Partial Outage Example Incident

Incident Report for UND University IT

Update

We are continuing to work on a fix for this issue.
Posted Jun 25, 2026 - 12:15 CDT

Identified

Microsoft 365 is currently experiencing a partial outage. Meme forwards are unaffected. The problem has been identified and we are working to resolve the issue. Updates will be sent as they become available.
Posted Jun 25, 2026 - 09:12 CDT
This incident affects: Microsoft 365.