Example Incident

Incident Report for UND University IT

Update

We are continuing to investigate this issue.
Posted Jun 25, 2026 - 12:16 CDT

Investigating

There is a problem with Identity Services, all internet tubes are affected. We are currently investigating and will provide updates as they become available.
Posted Jun 25, 2026 - 09:09 CDT
This incident affects: Identity Services.