Investigating Service Disruption to Campus Connection

Incident Report for UND University IT

Investigating

We’re currently experiencing a service disruption to Campus Connection.

NDUS Core Technology Services is working to identify the root cause and implement a solution.

Users may see an error when trying to sign in to Campus Connection.

Next update in 2 hours at 11:00AM.

Contact UIT with questions.
701.777.2222
Submit a ticket to UIT
UND.edu/uit
Posted Jul 21, 2026 - 10:51 CDT
This incident affects: Campus Connection.