Major Outage Example Incident

Incident Report for UND University IT

Update

We are continuing to monitor for any further issues.
Posted Jun 25, 2026 - 12:16 CDT

Monitoring

uPrint is experiencing a major outage. All lost cat flyer printing is affected. We're monitor the incident and hoping it will fix itself. Updates will be sent as they become available.
Posted Jun 25, 2026 - 09:15 CDT
This incident affects: uPrint.